There are plugins which allow your server to welcome players from multiple versions. If you do not know how to install plugins, refer to this guide.
To allow more recent Minecraft versions to join you need to install the plugin ViaVersion.

1.8.x servers will allow 1.8.x, 1.9.x, 1.10.x, 1.11.x, 1.12.x, 1.13.x
1.9.x servers will allow 1.9.x, 1.10.x, 1.11.x, 1.12.x, 1.13.x
1.10.x servers will allow 1.10.x, 1.11.x, 1.12.x, 1.13.x
1.11.x servers will allow 1.11.x, 1.12.x, 1.13.x
1.12.x servers will allow 1.12.x, 1.13.x

If you want to add backwards compatibility to your server (all the way back to 1.9) then you need to use a plugin called ViaBackwards which requires ViaVersion.
This allows all versions from 1.9.x to 1.13.x to join your server, but can be slightly buggy at times - however, the developers are improving it.

If you want to add backwards compatibility all the way back to 1.7.10 and 1.8 then you need to use a plugin called ViaRewind which also requires ViaVersion - however, this isn't from the officially supported by the developer of ViaVersion.
Was this article helpful?
Cancel
Thank you!